Главная » Настройки » Блок схема программы 1с предприятие. Требования к помещениям для эксплуатации пэвм

Блок схема программы 1с предприятие. Требования к помещениям для эксплуатации пэвм

Графическая схема - это общий объект встроенного языка . Она является одним из интерфейсных механизмов и позволяет создавать различные организационные, структурные и другие схемы для графического оформления прикладного решения. Графическая схема может использоваться как сама по себе, так и отображаться в формах и отчетах.

Элементы графической схемы

Для создания графической схемы может быть использовано довольно большое количество разнообразных элементов, которые можно разделить на три большие группы:

  • элементы, обозначающие точки карты маршрута бизнес-процесса;
  • декорации;
  • декоративные линии.

Элементы, обозначающие точки карты маршрута бизнес-процесса

Элементы, обозначающие точки карты маршрута могут быть использованы как для иллюстрации непосредственно бизнес-процессов, так и в качестве элементов различных блок-схем, иллюстрирующих выполнение тех или иных алгоритмов:

Декорации

Отдельную группу элементов представляют декорации, которые могут иметь несколько различных форм: блок, папка, файл, документ, эллипс, различные виды стрелок и скобок:

Декоративные линии

Декоративные линии могут использоваться как для соединения декораций, так и самостоятельно. Поддерживается несколько типов декоративных линий и несколько видов стрелок:

Оформление элементов графической схемы

Для всех элементов оформления поддерживается выбор цвета фона, линии, толщины линии. За исключением декоративных линий, поддерживается вставка картинок в элемент оформления. Соединительные и декоративные линии обеспечивают автоматическое скругление изгибов и перемещение некраевых "колен".

Все эти оформительские возможности позволяют создавать хорошо читаемые схемы даже в тех случаях, когда происходит частичное наложение соединительных линий.

Быстрая пошаговая демонстрация разработки приложения на платформе 1С:Предприятие 8.2.

Для выполнения примера вам понадобится платформа 1С:Предприятие 8.2. На нашем сайте вы можете скачать . Данная демонстрация подготовлена с использованием именно такой версии!

Простая система кадрового учета

Сейчас мы с вами создадим мини-систему кадрового учета сотрудников на предприятии. Она позволит нам принимать и увольнять сотрудников, а также работать с кадровыми документами.

Каждая конфигурация должна храниться в отдельном каталоге (папке).

1. Создайте новую папку на любом диске нашего компьютера, например, "C:\Наши кадры".

2. Запустите 1С:Предприятие. Откроется список информационных баз. Если вы не создавали ни одной информационной базы и не добавляли существующие базы, то список будет пустым.

1С:Предприятие может работать с несколькими базами данных на одном компьютере. Например, в одной базе ведется кадровый учет, в другой базе - учет товаров, в третьей - бухгалтерский учет для Фирмы А, в четвертой - бухгалтерский учет для фирмы Б.

3. Нажмите кнопку "Добавить".

На первом шаге мастера выберите вариант "Добавление в список существующей информационной базы".

На втором шаге укажите имя информационной базы, как оно будет отображаться в списке баз, например "Наши кадры". Имя базы может быть произвольным, от него ничего не зависит.

4. В следующем шаге укажите путь к папке, которую вы создали в 1 пункте нашего пошагового руководства (в нашем случае это C:\Наши кадры). Нажмите кнопку " …" , войдите в папку и нажмите "Выбрать".

Каталог с информационной базой может располагаться на локальном жестком диске компьютера, например "C:\Наши кадры", а может на другом компьютере в локальной сети, например, "\\SERVER\KADR". При этом должны быть предоставлены полные права доступа к этой папке (чтение, запись и т.д.).

Для ее редактирования можно нажать кнопку Изменить. Например, информационную базу перенесли в другое место или вы хотите задать для нее другое название. Для удаления информационной базы из списка нужно нажать кнопку Удалить. При этом информационная база удаляется из списка, но не удаляется физически с диска.

6. Выберем режим запуска "Конфигуратор". Для этого нажмем на кнопку «Конфигуратор».

1С может запускаться в двух режимах:

  • 1С:Предприятие - режим использования информационной базы. В этом режиме работают обычные пользователи, вводят данные, печатают отчеты и т.д. В этом режиме нельзя редактировать структуру конфигурации.
  • Конфигуратор - режим конфигурирования (программирования). В этом режиме работают программисты, создают новые справочники, отчеты, пишут программные модули. В этом режиме нельзя вводить данные в информационную базу.

7. Так как в созданной папке пока ничего нет, то 1С запросит подтверждение на создание новой информационной базы.

8. Нажмите "Да". Далее выбираем вариант "Создание информационной базы без конфигурации для разработки новой конфигурации или загрузки выгруженной ранее информационной базы" (2 вариант) и нажмите кнопку "Далее". На следующем шаге нажмите кнопку "Готово".

9. Запустится конфигуратор. Откройте дерево конфигурации, в котором мы будем работать очень часто. Для этого выберите в меню "Конфигурация" - "Открыть конфигурацию" или нажмите на соответствующую пиктограмму.

Появится окно дерева конфигурации. Задайте ему удобные размеры.

В этом окне представлены все объекты конфигурации, такие как справочники, документы, отчеты и т.д. Для раскрытия конкретной ветки нужно два щелкнуть на плюсике или два раза щелкнуть на ее названии.

Создание объектов конфигурации

10. Установите курсор на строку "Справочники" и щелкните кнопку (или щелкните правой кнопкой мыши и выберите Добавить). При этом откроется Окно редактирования объекта конфигурации (своеобразный конструктор для создания справочника).

Окно редактирования объекта конфигурации предназначены для быстрого создания новых объектов конфигурации. Последовательность ввода данных разработана таким образом, чтобы предыдущие данные могли служить основой для ввода последующих. Движение управляется кнопками в нижней части окна "Далее" и "Назад". На каждом шаге предлагается ввести группу логически связанных между собой данных. Перемещаться по шагам можно также щелкая мышкой по соответствующей вкладке (Основные, Подсистемы, Функциональные опции и т.д.).

11. На первом шаге (вкладке) задайте "Имя" нашего справочника (идентификатор), например, "Должности". После ввода Имени нажмите на клавиатуре клавишу "Enter", либо переместитесь мышкой на следующее поле. На основании "Имени" система автоматически создаст "Синоним".

Имя объекта (в нашем случае справочника) является важным и обязательным свойством любого объекта конфигурации. Именно оно будет использоваться при написании программного кода на языке 1С. Имя нельзя будет исправить просто так, поскольку придется также исправить все места в программе, где используется этот справочник.

Относитесь к "Имени" справочника очень серьезно. Имя должно быть лаконичным, понятным, отражающим суть справочника, например: "Страны", "Сотрудники", "Товары" и т.д.

Имена объектов конфигурации, реквизитов, переменных, процедур и функций в 1С могут содержать буквы русского и английского алфавитов (строчные и прописные), символы подчеркивания и символы цифр. Имя не может начинаться с цифр.

Свойство "Синоним" также есть у любого объекта конфигурации. Оно предназначено для хранения "альтернативного имени" объекта конфигурации (в нашем случае справочника). Именно оно будет использоваться в элементах интерфейса нашей программы, то есть будет показано пользователю. Для «Синонима» нет никаких ограничений и его можно задать в удобочитаемом виде, например, «Перечень должностей» и т.д.

У каждого справочника есть уже заранее заданные (предопределенные) два поля "Код" и "Наименование". Вы можете редактировать длину наименования, длину кода, а также тип кода: "Число" или "Строка".

13. Закройте Окно редактирования справочника "Должности".

14. Создадим новый справочник "Сотрудники" (см. пункт 10).

Задайте имя справочника (идентификатор) "Сотрудники".

Задайте длину наименования 100 символов.

В наименовании у нас будет храниться ФИО сотрудника. Иногда бывают довольно длинные имена и фамилии, так что 100 символов в самый раз.

15. В этом справочнике кроме уже заданных полей (Код и Наименование) у нас будет еще несколько полей (реквизитов, атрибутов). Сейчас список дополнительных реквизитов (полей) у нас пустой. Нажмите кнопку "Добавить".

В результате откроется окно редактирования свойств реквизита (палитра свойств). Кстати, реквизит, атрибут и поле - это в принципе одно и то же. Просто в терминологии 1С принято использовать "реквизит".

16. Задайте в палитре свойств имя реквизита - "Должность". Укажите тип реквизита - "СправочникСсылка.Должности", который мы создали раньше. Это говорит о том, что значения данного реквизита будут выбираться из справочника "Должности". Закрываем окно палитры свойств.

17. Создайте реквизит "Оклад" (тип Число, Длина 10, Точность 2). У значения типа "Число" точность указывает на количество знаков после запятой (в нашем случае 2 знака).

18. Создайте реквизиты ДатаПриема и ДатаУвольнения (тип Дата).

19. Теперь у нас есть два справочника и можно ввести некоторые данные.

Обновим конфигурацию базы данных (сохраним в конфигурацию все сделанные нами изменения). Сделать это можно с помощью меню программы (Конфигурация – Обновить конфигурацию базы данных), либо соответствующей пиктограммой на панели инструментов, либо клавишей F7.

Так как мы редактировали (изменяли) структуру информационной базы, то 1С проанализирует эти изменения и покажет окно со их списком. Нажмите кнопку "Принять".

20. Запустите систему в режиме 1С:Предприятие. Это можно сделать прямо из Конфигуратора, нажав на панели инструментов на или клавишу F5. Появится окно 1С:Предприятия.

21. Откройте справочник Должности. Для этого щелкните в панели навигации (в левой части окна приложения) по надписи (ссылке) Должности. Откроется окно справочника.

22. Введите несколько должностей, используя кнопку или клавишу INS. Например, директор, бухгалтер, программист.

Заметьте, что коды присваиваются автоматически, хотя их можно редактировать. При этом необходимо соблюдать уникальность кодов. Параметры уникальности можно настраивать в конфигураторе, например можно вообще отключить контроль уникальности кода.

По умолчанию установлена сортировка по Наименованию. Это позволяет набрать первые буквы названия должности, и курсор автоматически перейдет на нужную должность. Можно установить и другой тип сортировки: по коду или по реквизиту. Для этого достаточно щелкнуть левой кнопкой мышки по названию (заголовку) реквизита.

23. Откройте справочник Сотрудники.

24. Заведите нескольких сотрудников. Например, Иванов Иван Иванович - директор, Петров Петр Петрович - бухгалтер, Сидоров Сергей Сергеевич - программист. Заполняем только реквизиты Наименование (ФИО) и Должность. Заметьте, что при указании должности открывается справочник Должности. Для сохранения нового элемента справочника (новой записи) нажмите «Записать и закрыть».

25. Закройте окно 1С:Предприятие и вернитесь в режим Конфигуратора.

В реальной жизни принятие сотрудника на работу производится кадровым документом "Приказ о приеме на работу". Это мы и реализуем во 2 части нашего Пошагового примера.

«Бизнес состоит из двух вещей - люди и системы.» Джош Кауфман.

Внедрять или вести разработку 1С сложно. Речь идет не только о вопросах программирования. Прежде всего, речь идет о привязке процессов офиса (далее бизнес-процессов) к логике программы (или наоборот). А также об обучении пользователей и поддержке системы.

Вот перечень основных вопросов:

    Что хочет пользователь?

    Можно ли реализовать желания пользователя, купив «коробку» 1С?

    Если коробочное решение требует доработки, что именно следует дорабатывать? И сколько это будет стоить?

    Какую «коробку» купить, чтобы дорабатывать меньше?

    Наши «доработки» полностью устроят заказчика?

    «Доработка» написана правильно? Может это «плохой» код?

    Если доработали, сколько будет стоить обновление?

    Как обучить людей быстро и понятно работать в новой системе?

    Если люди увольняются и принимаются, сколько времени новичок будет учиться?

    Новичок будет учиться самостоятельно? Или у него будет инструкция?

    Кто поможет новичку научиться работе в системе?

    Уволенный сотрудник может не передать информацию новичку?

    Программист-разработчик может уволиться. Легко ли новому программисту будет поддерживать систему?

Как эти вопросы при разработке и внедрении «победить»?

Язык ДРАКОН - большинство вышеизложенных вопросов он решает, или решает частично.

Есть и свои минусы по сравнению со традиционным подходом программирования 1С:

    Тратим больше времени на описание задания.

Мое личное мнение - все эти минусы субъективные, но решать вам.

Надеюсь у тебя есть опыт внедрения или разрабатывал что нибудь в 1С-ке? Если ты планируешь нанять программиста, установить себе в контору «что нибудь», чтобы понять куда в твоем бизнесе уходят деньги. То тебе лучше почитать другую статью (напишу как время будет и размещу здесь ссылку). Вообще в сети куча такой литературы.

С чего начать?

Язык ДРАКОН остался бы языком с непонятной областью применения, если бы не было удобных «рисовалок» для простых смертных, для меня и для тебя. Обзор и сравнение этих продуктов делать в этой статье не буду (может позже ).

Найти этот продукт довольно просто:

    зайдите на последнюю страницу форума

    скачайте актуальную версию продукта, она обычно на последней странице форума

    установите

Сразу скажу, продукт платный есть «пробный» период - 15 дней.

Надеюсь 1С-ка у тебя стоит?

1С-ка "по быстрому"

Если тебя не волнует всякая муть как «дружить» пользователей с 1С. И тебе просто хочется побыстрей начать «кодить» в Драконе… . Вот тебе инструкция, читать слева на право:

Вот как «перемещать» объекты в схеме:

Как "дружить" пользователей и 1С

«Бизнес? Отделы? Маркетинг? Покажите мне деньги! Покажите мне «мясо»!» Из интервью какого-то олигарха.

Знакомая картина? Встреча с заказчиком (не так, вот так: Заказчик):

    «Вы 1С занимаитесь?» - Заказчик

    «Да» - Программист 1С

    «Купили 1С, знакомый программист установил, данные из старой 1С-ки перенес. Да вот стали ему вопросы по работе задавать, и он отвечал как-то «вяло» а потом пропал. Телефон не берет и вообще… . Можете помочь?» - Заказчик

    «Надо глянуть… . А что купили?» - Программист 1С

    «Вот коробка… . 1С «Управление небольшой фирмой». Вот… Бухгалтер она вам все покажет. Мы делаем мебель. Нужны отчеты по складу, кассе. Пока отсюда начнем. Потом нужно считать зарплату. Хочу знать прибыль. А то запутался совсем - мы прибыльные или нет?» - Заказчик

    «Надо глянуть…» - Программист 1С

    «Сколько будет стоить?» - Заказчик

    ««Х» рублей в час» - Программист 1С

    «А сколько времени займет?» - Заказчик

Вопрос оценки работы подробно рассматривать не буду - у каждого она своя. Вот что надо сделать, как я понял. Есть уже купленная «конфа». Почему именно она? Кто выбирал? Вопросы без ответов… . Главный вопрос: как ее «дружить» с этой фирмой и сколько это выйдет Заказчику? Отсюда будет ответ на вопрос, сколько я заработаю = сколько я потрачу времени и сколько часов мне оплатят? Надо понимать Заказчик хочет дешево, я хочу сколько нужно. Надо договориться. Договариваться нужно с аргументами в руках, желательно «с цифрами». Чтобы их получить «+/- километр», надо вникнуть в суть работы компании: описать бизнес-процессы. Поехали.

Поговорил - нарисовали такую схему:

Да, любой бизнес-аналитик скажет: «Детское творчество!». Но «Яж программист» - мне «фиолетово», главное я могу теперь взять эту схему и начать предметный разговор и меня люди поймут (поймут, поймут - проверено на людях ).

Дальше. Надо бы понять, примерно, что за «конфу» купил Заказчик (купил же уже). Берем схему, найдем инструкцию по «конфе» и попытаемся, читая схему и инструкцию понять, насколько «конфа» подходит к схеме работы. Если он бы купил «ЗУП» и пытался бы эту схему в ней реализовать - сам понимаешь, ничего не выйдет. Тогда идем к Заказчику и говорим, что или «конфу» надо другую (вот эту например …) или поищите другого «тыж программиста».

В нашей истории «конфа» более менее подходит. Пока… . Беремся. Идем к Заказчику - рапортуем, и, главное, что будем делать в первую очередь узнаем. В нашей истории Заказчик попросил реализовать складской учет сначала. После разговора с кладовщиком наша основная схема принимает вот такой вид:

Как видно, элемент №9 теперь стал «Вставкой» - ссылкой на другую схему. Расшифруем схему работы Кладовщика, для модуля-вставка №9 из предыдущей схемы:

Получаем инструкцию по оприходованию товара Кладовщиком:

Нарисовали. Теперь садимся рядом с Кладовщиком и пытаемся эту схему реализовать. И вот, «всплывает». Оказывается, параметры печати нужно каждый раз менять вручную. Непорядок. Сделаем доработку, чтобы параметры печати устанавливались сами. И отразим это в схеме:

Внимание на элемент схемы №197. Так я отражаю изменения в конфигурации. Этот элемент входит в «Параллельные действия» с элементом №193. Это значит, что моя доработка «включается» когда пользователь нажимает эту кнопку. Заголовок «Доработка МФК-0002» означает, что эта доработка так называется в моих каталогах (веду маленькую картотеку своих работ, Дракон мне в этом помогает…). Эта доработка: просто пара строк в уже написанном коде. Оформление более серьезных доработок рассмотрим позже.

Имя модуля содержит краткий смысл доработки и адрес внесенных строк в конфигураторе. Текст доработки находиться в 3-ей точке ввода (видно, что она черного цвета). Вот текст, который вы там могли бы увидеть:

""ТабДок = Элемент.Значение; //+ААА Задать параметры при печати этикеток Если Найти(ТабличныеДокументы.Представление, "Этикетка") > 0 Тогда ТабДок.ПолеСверху = 0; ТабДок.ПолеСнизу = 0; ТабДок.ПолеСлева = 0; ТабДок.ПолеСправа = 0; ТабДок.РазмерКолонтитулаСверху = 0; ТабДок.РазмерКолонтитулаСнизу = 0; ТабДок.АвтоМасштаб = Истина; КонецЕсли; //-ААА Задать параметры при печати этикеток ТабДок.Напечатать(РежимИспользованияДиалогаПечати.НеИспользовать);""

Ничего сложного, как видите.

Подведем маленький итог на основе вопросов, заданных выше:

1. Что хочет пользователь?

2. Можно ли реализовать желания пользователя, купив «коробку» 1С?

    Сравнили дракон-схему и инструкцию по «конфе» - нужны будут небольшие доработки.

3. Если коробочное решение требует доработки, что именно следует дорабатывать? И сколько это будет стоить?

    Не понятно пока, но скорее всего будут «небольшие» доработки. Ничего особо затратного.

4. Какую «коробку» купить, чтобы дорабатывать меньше?

    Изначально купленная конфигурация подходит. Опять таки исходя из проведенного выше сравнения дракон-схемы и Инструкции по «конфе».

5. Наши «доработки» полностью устроят заказчика?

    Наша доработка «маленькая» и полностью оправдана.

6. «Доработка» написана правильно? Может это «плохой» код?

    Думаю да.

7. Если доработали, сколько будет стоить обновление?

    Есть четко описание, что, зачем и как изменили - обновить будет легко.

8. Как обучить людей быстро и понятно работать в новой системе?

    Инструкции из дракон-схемы для пользователей получаются подробные и полные. Люди легко учатся.

9. Если люди увольняются и принимаются, сколько времени новичок будет учиться?

    Инструкции есть - учиться будет быстро.

10. Новичок будет учиться самостоятельно? Или у него будет инструкция?

    Инструкции есть - учиться будет легко.

11. Кто поможет новичку научиться работе в системе?

    Инструкция есть - полная и подробная. Она поможет. В крайнем случае - мой приемник или начальник ему поможет.

12. Уволенный сотрудник может не передать информацию новичку?

    Все инструкции, в виде дракон-схем, в электронном и/или печатном виде храняться у руководства компании. И легко выдаются по мере необходимости.

13. Программист-разработчик может уволиться. Легко ли новому программисту будет поддерживать систему?

    Сохраняются все дракон-схемы с подробным описание доработок, их логики. Да, легко будет поддерживать. Конечно код специфический, но «кодить» можно прямо из «ИС Дракон». Думается, когда есть описание логики доработок - «специфический» код «малое» зло по сравнению с тем, когда просто ничего нет, кроме «невнятных» комментариев (а бывает, что и их нету).

История возникновения информационных технологий уходит своими корнями в глубокую древность. Первым этапом можно считать изобретение простейшего цифрового устройства – счетов. Счеты были изобретены совершенно независимо и практически одновременно в Древней Греции, Древнем Риме, Китае, Японии и на Руси.

Цифровое направление развития техники вычислений оказалась более перспективным и составляет сегодня основу компьютерной техники и технологии. Первая построенная механическая цифровая машина была создана французским философом и механиком Блэзом Паскалем в 1642г. В начале XIX века Жозефа Мари Жаккара применил для управления ткацким станком карту с пробитыми отверстиями (перфокарту). Ученые использовали это открытие для создания новой счетной машины, выполняющей операции без вмешательства человека. Далее развитие цифровой техники вычислений происходило быстрыми темпами. Изобретались более скоростные и малогабаритные компьютеры, которые имели повышенное быстродействие и пониженное потребление энергии. В середине 70-х появились первые персональные компьютеры. Дальнейшая история компьютеров тесно связана с развитием микропроцессорной техники. 12 августа 1981 г. появился компьютер IBM PC. За двадцать лет с момента выхода IBM PC изменился его внешний вид, расширились функциональные возможности. В значительной степени возросла интеграция компьютерной техники в повседневную жизнь каждого человека.

Во второй половине XX в. человечество вступило в новый этап своего развития. В этот период начался переход от индустриального общества к информационному. Процесс, обеспечивающий этот переход, получил название информатизация. Информатизация – это процесс создания, развития и всеобщего применения информатизационных средств и технологий, обеспечивающих достижение и поддержание уровня информированности всех членов общества, необходимого и достаточного для кардинального улучшения качества труда и условий жизни в обществе. При этом информация становится важнейшим стратегическим ресурсом общества и занимает ключевое место в экономике, образование и культуре.

Неизбежность информатизации общества обусловлена резким возрастанием роли и значения информации. Информационное общество характеризуется высокоразвитой информатизационной сферой, которая включает деятельность человека по созданию, переработке, хранению, передаче и накоплению информации.

Информатизация – необходимое условие научно-технического, социального, экономического и политического прогресса в обществе.

Процесс перехода от постиндустриального общества к информационному происходит не одновременно в различных странах, он характеризуется также различными темпами развития. По мнению специалистов, любая страна, насколько бы индустриально развитой она не была, перейдет в разряд стран третьего мира, если опоздает с информатизацией. Таким образом, информатизация в обществе имеет существенное значение, потому что информационные ресурсы используются в разных областях человеческой деятельности, становятся достоянием любого пользователя, организации. Информатизация позволяет повысить производительность труда, качество труда и уровень жизни всего общества.

1. Технологическая часть

1.1 Анализ предметной области

Преддипломная практика проходила на предприятии ОАО «Кировэнерго» ЯЭС в отделе АСУ

Данный отдел занимается преимущественно информационными системами. Одним из направлений деятельности является обслуживания установленной там системы 1С: Предприятие. Система 1С: Предприятие и была одним из объектов изучения в ходе преддипломной практики.

Целью данного дипломного проекта является разработка модуля для предприятия, занимающегося сборкой компьютеров. Нужно разработать такой модуль, который бы значительно увеличил производительность предприятия.

В первой главе рассмотрена структура предприятия. Проведен обзор и сравнение аналогов имеющейся ИС, их сравнению и выбору наиболее подходящей. Произведено описание предметной области, произведен анализ функциональности информационной системы. И разработан сам модуль.

Во 2 главе производится расчет экономической эффективности внедряемой информационной системы.

Последняя 3 глава дипломного проекта затрагивает вопросы безопасности жизнедеятельности

Ниже будет произведен анализ предметной области.

1.1.1 Организационная структура предприятия

Организационная структура предприятия является иерархической (древовидной). Во главе фирмы стоит генеральный директор. Он управляет всем предприятием, и ему подчиняются все службы, входящие в состав фирмы. Графическое представление организационной структуры предприятия представлено на рисунке 1

Рисунок 1 - Графическое представление организационной структуры предприятия

Выделим работников и фирмы и их функции:

Руководство – управленческие функции, отчетность;

Финансовый отдел – управление ценовой политикой;

Мастера – сборка;

Менеджеры - работа с клиентами, поставщиками;

Маркетолог – планирование и анализ.

Технический персонал (кладовщики, водители) – доставка, погрузка;

Бухгалтерия и кассиры – расчет стоимости услуг, работа с платежами.

Администратор - осуществляет функции формирования единой БД, формирования резервных копий БД, управления правами доступа к системе, осуществляет функции настройки системы.

1.1.2 Функциональная структура предприятия

Выделим основные подсистемы в структуре предприятия. Таковыми являются:

Бухгалтерия.

Работа с клиентами

Планирование и анализ

Работа магазина

1) «Бухгалтерия»: расчет и формирование платежных документов; расчет и формирование накладных и счетов-фактур; расчет заработной платы; учет текущей документации; учет пенсионного фонда; расчет и формирование документов по отчетности; анализ документов о движении товаров на складе;

2) «Работа с клиентами»: обсуждение планируемого оформления, формирование и заключение договоров с клиентами.

3) «Планирование и анализ»: планирование и анализ реализованной продукции, планирование и анализ поступаемой продукции, анализ торгового периода, анализ заказов, учет складского движения товара.

4) «Работа магазина»: продажа комплектующих и продукции в сборке, хранение, сборка

1.2 Обзор существующего программного обеспечения

Ниже будут приведены краткие характеристики систем, которые предназначены для решения сходных задач с 1С версии7.7.

1.2.1 Галактика

Галактика Business Suite - полнофункциональный комплекс бизнес-решений, позволяющий в едином информационном пространстве выполнять типовые и специализированные задачи управления предприятием, холдингом, группой компаний в условиях современной экономики. На рисунке 2 представлена структура Галактика Business Suite.

Рисунок 2 – Структура Галактика Business Suite

Комплекс Галактика Business Suite на основе передовых информационных технологий обеспечивает решение:

1) всего спектра управленческих задач предприятия в соответствии с концепцией ERP;

2) задач поддержки принятия управленческих решений на базе определения, планирования, достижения и анализа ключевых показателей деятельности предприятия;

3) задач корпоративного управления, связанных с консолидацией информации, поступающей из территориально-распределенных подразделений/предприятий, и управлением распределенными ресурсами (материальными, финансовыми, трудовыми).

Управление эффективностью бизнеса (Corporate Performance Management, CPM) - решение задач распределенных многоуровневых бизнес-сообществ, холдингов и корпораций. Возможность организации единого информационного пространства не только внутри корпорации, но и по отношению к клиентам и партнерам, интеграции внешних приложений синхронизации данных и бизнес-процессов. Синхронизация справочников и данных с внешними системами.

В комплексе Галактика Business Suite отражены передовые методологии и концепции управления, новейшие разработки в области информационных технологий:

1) Предприятие реального времени (Real-Time Enterprise, RTE) - получение оперативной и достоверной информации о выполнении важных и критических процессов, помощь в принятии решений в нужный момент, способность быстро адаптироваться к потребностям изменяющейся бизнес-модели управления предприятием.

2) Сервисная шина предприятия (Enterprise Service Bus, ESB) - интеграция в единое информационное пространство распределенных структур, работающих с гетерогенными системами. Уникальная технология, которая ранее из-за ее стоимости была доступна только крупным компаниям.

3) Система управления бизнес-процессами (Business Process Management, BPM) - повышение эффективности функционирования процессов и качества управления, контроль и управление регламентными операциями, динамическое совершенствование процессов, гибкость и удобство в работе.

4) Мобильный бизнес - построение мобильного бизнеса с динамичной структурой, интеграция с партнерами через Интернет, поддержка мобильных устройств, Интернет-магазинов.

Ядром комплекса Галактика Business Suite является система Галактика ERP. Возможности системы дополняются и расширяются с помощью решений «Галактики» на платформе Галактика Ranet, которые представляют собой готовые продукты и могут быть легко адаптированы под потребности конкретного заказчика: Галактика Business Intelligence и Галактика Financial Management.

Специально для средних предприятий на базе системы Галактика ERP было разработано решение Галактика Старт, позволяющее быстро и с минимальными затратами провести автоматизацию основных бизнес-процессов предприятия. Небольшие, динамично развивающиеся компании могут воспользоваться и специальным предложением корпорации «Галактика» - решением Галактика Прогресс.

Возможности системы позволяют в едином информационном пространстве оперативно решать главные управленческие задачи, обеспечить менеджеров различного уровня управления необходимой и достоверной информацией для принятия управленческих решений.

Построение системы учета и формирование различных видов отчетности

Управление материальными и финансовыми потоками

Финансовое планирование и оперативный финансовый менеджмент

Производственное планирование и управление, контроллинг

Управление качеством продукции

Управление персоналом и реализация кадровой политики

Управление взаимоотношениями с клиентами

Отличительные особенности решений корпорации «Галактика»:

1. Соответствие концепции ERP и стандарту MRP-II

2. Современные методики управления и учет российской специфики

3. Поддержка национальных и международных стандартов финансовой отчетности

4. Масштабируемость.

5. Возможность быстрого внедрения

6. Простота и надежность.

1.2.2 Microsoft Axapta

Microsoft Axapta - комплексное ERP-решение, созданное специально для средних и крупных компаний, которое позволяет им расширить свои возможности и приобрести новые конкурентные преимущества. Microsoft Axapta идеально подходит для компаний, ищущих полностью интегрированное решение.

Microsoft Axapta охватывает все сферы бизнеса, включая производство и дистрибуцию, управление цепочками поставок и проектами, финансовый менеджмент и средства бизнес-анализа, управление взаимоотношениями с клиентами и управление персоналом.

Microsoft Axapta обладает следующими свойствами:

1) Универсальность

Система соответствует всем требованиям российских и международных стандартов бухгалтерского учета и законодательства, может работать на множестве языков и с разными валютами.

2) Масштабируемость

При первой инсталляции Microsoft Axapta происходит установка всех функций системы. Неиспользуемые функциональные возможности остаются скрытыми от пользователей и активируются при вводе в систему соответствующих лицензионных кодов.

3) Работа в нескольких компаниях

В рамках одной инсталляции Microsoft Axapta можно вести оперативный и финансовый учет независимо в нескольких компаниях, сокращая при этом расходы на поддержку и обновление системы. Такая модель работы идеально подходит для компаний, имеющих несколько офисов, филиалов или дочерних компаний.

Картотеки клиентов и поставщиков, план счетов Главной Книги и другие данные могут быть как общими для всех компаний, так и уникальными для каждой компании в зависимости от потребностей Вашего бизнеса. Система также поддерживает торговые операции между компаниями.

В основе Microsoft Business Solutions-Axapta заложены самые современные западные технологии управления и высокотехнологичные решения, позволяющие эффективно управлять предприятием. . Система в большей степени подходит для автоматизации бизнес-процессов в рамках управленческого учета для средних и крупных предприятий различных областей хозяйственной деятельности.

Axapta - это ERP система, работающая в среде электронного бизнеса. Уникальность системы Axapta заключается в том, что ее современная технология обеспечивает единое информационное пространство предприятия, в котором бэк-офис и фронт-офис работают как единое целое. Axapta предлагает ряд возможностей для бизнес-анализа, что облегчает процесс принятия решений и комплексное управление отношениями с клиентами (CRM).

Основными модулями системы Axapta являются:

Финансы;

Торговля и Логистика;

Производство;

Электронная Коммерция;

Управление Персоналом;

Проекты;

Управление Взаимоотношениями с Клиентами (CRM - Customer Relationship Management);

Управлением Знанием (KM - Knowledge Management);

Управление Логистическими Цепочками (SCM - Supply Chain Management) и другие.

Большой набор функциональных возможностей системы Axapta позволяет получить ряд определенных преимуществ:

Более низкие затраты на создание и поддержку системы;

Легкость в обновлении приложений;

Баланс избыточной информации;

Полная интеграция бизнес-процессов.

1.2.3 infor: COM

infor:COM – полномасштабная система класса ERP для предприятий среднего сектора рынка, которая обеспечивает совместную работу всех функциональных подразделений предприятия, давая тем самым необходимую слаженность в работе подразделений.

Особенности:

1) infor:COM разработана компанией infor business solutions AG переведена на русский язык и адаптирована к российским нормам и практике ведения бизнеса.

2) Система объединяет в единое целое модули планирования ресурсов предприятия (ERP), планирования производственных (материальных) ресурсов (MRP, MRPII), управления отношениями с клиентами (CRM), электронной коммерции (e-business) и управления цепочками поставок (SCM).

3) Базовый пакет обеспечивает функции по ведению продаж, закупок, склада, производства, планированию ресурсов, ведению корпоративных справочников и управлению системой. Кроме этого в систему в любое время можно добавить дополнительные функции.

4) Помимо обширного комплекта стандартных отчетов, входящего в комплект поставки, пользователь может получить доступ к хранящейся в системе информации с помощью других средств: специального генератора отчетов, встроенных интерфейсов с программами MS Word, MS Excel, а также технологии ODBC (открытый интерфейс доступа к базам данных), обеспечивающей доступ к стандартным форматам баз данных; MS SQL-сервера или Oracle.

1) В сфере продаж система infor:COM обеспечивает возможность работы с коммерческими предложениями во взаимосвязи с остальными функциями. Процесс ценообразования может охватывать как производимые на самом предприятии, так и закупаемые изделия. В системе можно отслеживать всю историю изменений коммерческого предложения. Предложение можно преобразовать в заказ без повторного ручного ввода данных.

2) Заказы на продажу можно использовать для создания производственных заданий или специализированных заказов на ремонт или сервисное обслуживание. Система позволяет контролировать процесс исполнения заказов, управлять их статусами.

3) В infor:COM предусмотрена мощная система разграничения полномочий. Так, только уполномоченные лица имеют право оформлять заказы на закупки.

4) Система обрабатывает заявки на коммерческие предложения поставщиков и ведет их архив.

5) Расчет потребностей, планирование производства, закупок и т.д. может осуществляться по всей цепочке поставок. Список заказов может быть автоматически отправлен по факсу, электронной почте и через Интернет. Модуль “Склад” поддерживает все складские операции. Пользователь может получить графическую сводку складских местонахождений, запасов и их статуса, от стандартных складов до пунктов проверки качества и местонахождений приостановленных заказов. Ведется документирование всех складских процедур.

6) Система позволяет осуществлять детальное планирование всех ресурсов. Обратное, прямое и промежуточное планирование позволяют контролировать выполнение заказов и выделять производственные ресурсы с учетом точной информации о загрузке персонала и материалов. С помощью этого можно сократить время выполнения заказов и достичь более высокой производительности труда.

7) Учет себестоимости производимой продукции является одним самых сильных мест системы infor:COM. Модуль “Расчет себестоимости” позволяет в любое время вычислить все фактические затраты, относящиеся к заказу или проекту, а также отклонение от плановых затрат. Возможно включение административных и управленческих расходов, учет нормы прибыли. Производится настройка пользовательских типов затрат. Посмотреть себестоимость заказа можно из любого места системы – в том числе из заказа.

8) В сфере производства система позволяет контролировать выпуск продукта, управление производством, учет расходов сырья, контроль за процессом изготовления. Предусмотрены средства управления рабочими мощностями, сроками и трудовыми ресурсами, расширенные возможности планирования и анализа, предоставление управленческой информации в максимально наглядной форме. Предусмотрено объединение производственных участков в группы и ведение альтернативных участков, ведения гибких настраиваемых производственных графиков (для каждого производственного участка возможна настройка любого расписания смен, которое будет учитываться при планировании производственных мощностей).

9) Данные infor: COM, организованные в виде набора справочников удобной структуры, не являются “пассивно-информативными”, а глубоко интегрированы в процедуры обработки. Фактически, тщательно настроенная система позволяет создавать в автоматическом режиме до 100% производственных и закупочных заказов на основе потребностей, обусловленных имеющимся набором заказов или совокупным производственным планом.

10) Необходимо особо отметить технологию генерирования вариантов, реализованную в системе: так, может вестись расчет себестоимости и сроков изготовления в зависимости от вариантов комплектации, материала изделий и других параметров. Эта технология позволяет в режиме реального времени настраивать параметры обработки. Например, в зависимости от параметров введенного заказа, корректировать ценовые условия заказа или вносить необходимые изменения в технологическую карту заказываемого продукта: детализировать информацию о необходимом сырье, маршрутизации, планируемом времени выполнения и т.д.

11) В стандартный комплект infor:COM входят мощные средства настройки системы. В первую очередь это касается разработки пользовательских отчетов на базе популярного генератора отчетов Crystal Reports, run-time версия которого включена в стандартную поставку. infor Dialog Manager, также входящий в стандартную комплектацию системы, позволяет редактировать любые формы или процедуры обработки. Инструментарий контроля версий обеспечивает легкую переносимость настройки при смене версий базовой программы.

1.2.4 1С: Предприятие

Рассмотрим программный продукту фирмы «1С» и выделим её преимущества.

«1С:Предприятие» включает в себя платформу и прикладные решения, разработанные на ее основе, для автоматизации деятельности организаций и частных лиц.

Сама платформа не является программным продуктом для использования конечными пользователями, которые обычно работают с одним из многих прикладных решений (конфигураций), разработанных на данной платформе. Такой подход позволяет автоматизировать различные виды деятельности предприятий, используя единую технологическую платформу.

Состав прикладных механизмов «1С:Предприятия» ориентирован на решение задач автоматизации учета и управления предприятием. Использование проблемно-ориентированных объектов позволяет разработчику решать самый широкий круг задач складского, бухгалтерского, управленческого учета, расчета зарплаты, анализа данных и управления на уровне бизнес-процессов.

Гибкость платформы позволяет применять «1С:Предприятие» в самых разнообразных областях:

Автоматизация производственных и торговых предприятий, бюджетных и финансовых организаций, предприятий сферы обслуживания и т.д.;

Поддержка оперативного управления предприятием;

Автоматизация организационной и хозяйственной деятельности;

Ведение бухгалтерского учета с несколькими планами счетов и произвольными измерениями учета, регламентированная отчетность;

Широкие возможности для управленческого учета и построения аналитической отчетности, поддержка многовалютного учета;

Решение задач планирования, бюджетирования и финансового анализа;

Расчет зарплаты и управление персоналом.

1.3 Сравнение систем и выбор оптимальной системы.

В таблице 1 представлена сравнительная характеристика систем.


Таблица 1 - Сравнение систем.

Название

Сфера применения

Особенности

Цена внедрения

Галактика Business Suite

Крупные и средние предприятия, бизнес-сообщества, холдинги и корпорации

Соответствие концепции ERP и стандарту MRP-II.

Современные методики управления и учет российской специфики

В зависимости от конфигурации и пользователей: от 5000 до 100000 руб

Средние и крупные компаний

Универсальность (Система соответствует требованиям российских и международных стандартов.)

Работа в нескольких компаниях

Модуль интеграции: от5000 до 170000$

Средний сектор рынка

Адаптирована к российским нормам и практике ведения бизнеса.

Система объединяет в единое целое модули:ERP,MRP, MRPII, CRM, электронной коммерции (e-business), SCM

около 1,5 тыс. долл. на рабочее место.


1С:Предприятие

Крупный, средний и малый бизнес

Использование конфигураций, позволяющих автоматизировать различные виды деятельности предприятий, используя единую технологическую платформу.

Ориентирована на русского пользователя

В зависимости от конфигурации и пользователей: от 3000 до 60000 руб

Более предпочтителен для нашего предприятия продукт «1С:Предприятие» в виду следующих причин:

1) Достаточная низкая цена по сравнению с другими продуктами.

2) Повышена производительность по сравнению с аналогичными системами.

3) Гибкая настройка под конкретное предприятие.

4) Существование стандартных механизмов перехода от более старой версии к новой, таким образом, нет необходимости создавать новую БД.

5) Ориентирована на русского пользователя. Следовательно, менее сложное обучения персонала.

1.4 Система 1С: Предприятие

1С-Предприятие является гибкой настраиваемой системой для решения широкого круга задач в сфере автоматизации деятельности предприятий. На рисунке 3 приведена схема взаимодействия различных компонентов 1С: Предприятия.


Рисунок 3 – Схема взаимодействия компонентов 1С: Предприятия

Одной из характерных особенностей программ, является их масштабируем ость: одна и та же конфигурация может работать на локальном компьютере, в сети и на сервере под управлением MS SQL Server 7.0.

Конфигуратор. Все начинается с запуска Конфигуратора. Программы для 1С:Предприятие называются "конфигурациями" и создаются они в специальном режиме для разработчика "Конфигуратор". Обычные пользователи работают в режиме "Предприятие".

Объекты, свойства и методы. Самое главное понятие 1С - это "объект". Объект - это элемент реального мира. Объектом может быть все что угодно: компьютер, облако, кошка... Но нас интересуют только те объекты, которые имеются в офисной деятельности предприятия: документы, отчеты, справочники... Программа для 1С представляется как совокупность объектов, взаимосвязанных между собой, т.е. конфигурация объектов. Например, документ "Приказ о приеме на работу", справочник "Сотрудники", отчет "Сотрудники, принятые за период".

У объектов имеются некоторые атрибуты (свойства, реквизиты). Например, сотрудник имеет фамилию, имя, отчество, оклад, табельный номер. Приказ о приеме имеет номер и дату. Набор свойств объекта задается разработчиком.

Также объекты имеют определенные методы (процедуры и функции). Например, вы можете выбрать всех сотрудников с помощью метода справочника Выбрать Элементы (), или можно сохранить документ методом Записать().

Встроенный язык. Поведение объектов конфигурации задается на встроенном языке. Программист может писать на встроенном языке 1С свои собственные модули, состоящие из процедур и функций. Встроенный язык позволяет работать со справочниками, документами и другими объектами 1С. Можно, например, с помощью методов объектов выбрать все элементы справочника Сотрудники для вывода в отчет, или создать и сохранить любой документ.

Модули, процедуры и функции. Вся конфигурация, как вы уже наверное заметили, состоит из модулей. Это могут быть модули документов или модули отчетов или другие модули. Модули состоят из процедур и функций. Процедура - это небольшая программа для выполнения определенной задачи. Функция отличается от процедуры, только тем, что имеет результат. Говорят, "функция возвращает результат". Например, модуль "Приказа о приеме на работу" может иметь следующие процедуры ПроверитьПравильность() и НапечататьПриказ().

Глобальный модуль. В системе 1С есть так называемый Глобальный модуль. Он относится к конфигурации в целом. Глобальный модуль нужен для того, что писать процедуры и функции, доступные в любом месте программы (в любом другом модуле). Для этого необходимо просто указать ключевое слово Экспорт. Также можно создать глобальные переменные, которыми можно будет пользоваться в любом месте программы. Но чем меньше будет таких глобальных переменных, тем лучше, так как модули получаются более независимыми друг от друга, что снижает количество ошибок в программе и облегчает отладку.

1.4.1 Назначение конфигуратора

Конфигуратор системы 1С:Предприятие является специальным режимом запуска 1С и предназначен для разработчиков, программистов. В этом режиме разработчик создает или корректирует структуру базы данных, программные модули, производит административные работы. В режиме Конфигуратора нельзя вводить информацию в базу данных, за исключением загрузки базы данных из архивов. Обычные пользователи работают в другом режиме "Предприятие". В этом режиме возможен ввод данных, заполнение справочников и ввод документов, формирование отчетов и запуск обработок. В режиме Предприятие нельзя редактировать структуру конфигурации.

В режиме Конфигуратор - мы определяем структуру базы данных и пишем программы. В режиме Предприятие мы используем программы и вводим данные.

Основное окно конфигуратора. (рисунок 4)

Рисунок 4 – Основное окно конфигуратора

Слева находится дерево конфигурации, в котором редактируется структура базы данных.

Справа окно Синтакс-помощника, которое часто используется при написании программных модулей для того, чтобы вспомнить синтаксис или параметры конкретной процедуры/функции.

Дерево конфигурации (метаданные)

Рисунок 5 – Древо конфигурации.

В окне конфигурации можно раскрывать списки объектов (константы, справочники, документы и т.д.). Объекты можно добавлять, удалять, редактировать, изменять их порядок, сортировать, писать для них описание.

Каждый объект имеет свойства и контекстное меню (вызывается правой кнопкой мыши).

Также к конфигурации относятся Интерфейсы и Права. Для их вызова нужно щелкнуть вкладки, расположенные внизу дерева конфигурации.

Кроме того, когда окно дерева конфигурации активно в меню Действия становятся доступными пункты "Глобальный модуль", "Общие таблицы" и "Библиотека картинок".

Редактор форм

У многих объектов конфигурации есть экранные формы. В частности экранные формы в версии 7.7 имеют справочники, документы, журналы документов, отчеты, обработки, журналы расчетов, журнал операций, журнал проводок, план счетов и счет. У некоторых объектов может быть несколько экранных форм, например, у справочников есть формы списков, форма элемента и форма группы.


Рисунок 6 – Форма документа

Поясним значение кнопок панели редактора форм:

Эти кнопки становятся доступными, когда выделено несколько элементов управления на форме. Они позволяют выравнивать их по левому, по правому, по верхнему и по нижнему краю.

Эти кнопки центрируют выделенные элементы управления относительно всей формы по вертикали или горизонтали.

Эти кнопки равномерно распределяют выделенные элементы управления по вертикали или горизонтали.


Эти кнопки делают выделенные элементы управления одной ширины, одной высоты или одного размера. Определяющим является элемент управления, выделенный последним. Два элемента управления можно выделить, удерживая кнопку Shift и щелкая поочередно на каждом из них.

Включить/выключить решетку. Запустить тестовое окно (проверить форму в режиме конфигуратора). Вызвать окно редактирования слоев формы (попробуйте обязательно - это очень важно!).

Разберем кнопки на панели элементов управления:


Эта кнопка вызывает что-то типа мастера элементов диалога. Можно быстро разместить любой элемент управления, назначить ему тип, присвоить вызов процедуры и т.д.

Эта кнопка размещает на форме обычную кнопку. В свойствах кнопки в поле Формула пишется имя процедуры, которая будет запущена при нажатии на кнопку.

Эта кнопка размещает на форме флажок. В свойствах флажка в поле формула пишется имя процедуры, которая будет запущена при установке или снятии флажка.


Эта кнопка размещает на поле переключатель. Переключатели имеют смысл, когда их несколько, в этом случае пользователь производит выбор между несколькими вариантами. Чтобы переключатели заработали, нужно сделать следующее: для первого переключателя установить в свойствах флажок "Первый в группе". Далее проверить, чтобы порядок обхода элементов был точно в том порядке, в котором следуют переключатели (Действия => Настройка порядка обхода). Типичный камешек для новичков.

Эта кнопка размещает на форме список значений. При этом по имени списка можно обращаться к нему из модуля (объект СписокЗначений). Можно добавлять значения в список, удалять значения и делать все другие операции, возможные для объекта СписокЗначений.

Эта кнопка размещает на форме поле со списком значений. При этом также создается объект СписокЗначений. Обратите внимание что лучше задать БОЛЬШУЮ ВЫСОТУ этого элемента управления, чтобы список раскрывался. Типичный камешек для новичков.

Обычная рамка. Можно визуально объединить несколько элементов управления. Служит для удобства пользователя.

Текстовое поле. Если в поле Формула вписать имя функции, то при каждом обновлении формы 1С будет вызывать вашу функцию и ее результат будет отображаться в этом поле. Кстати, если щелкнуть на эту кнопку и затем щелкнуть на табличной части справочника, документа или журнала, тогда мы создадим текстовую колонку. Она не будет сохраняться в базе данных, но у нее есть поле Формула, куда можно написать любое выражение. Очень полезная вещь для всяких информационных колонок. Типичная непонятность для новичков.

Поле для ввода данных. Для поля можно назначить любой тип данных, допустимый в 1С:Предприятие. В поле Формула можно написать имя процедуры, которая будет вызываться при изменении значения данного поля. ВНИМАНИЕ: для размещения на форме реквизитов справочников и документов пользуйтесь кнопкой: . Типичный камешек для новичков.

Эта кнопка размещает на форме таблицу значений. По имени таблицы значений к ней можно обращаться из модуля. Колонки и строки таблицы создаются программным способом (см. объект ТаблицаЗначений).

Для иерархических справочников на форме списка можно разместить дерево групп.

Эта кнопка размещает на форме картинку. Управление картинкой осуществляется программным способом (см. объект Картинка).

Эта кнопка размещает на форме поля для ввода данных, связанные с реквизитами справочников и документов. Только в этом случае, введенные данные будут сохраняться в базе данных.

Для удобства пользователей обязательно настройте последовательный порядок обхода элементов диалога! При интенсивном вводе информации желательно максимальное использование клавиатуры. Порядок обхода настраивается следующим образом. В меню Диалог снимаете флажок "Автоматический порядок обхода". Затем опять в меню Диалог щелкаете "Порядок обхода" и последовательно щелкаете на номерах элементах диалога в том порядке, в котором они должны быть. Порядок обхода можно также редактировать в меню Диалог => "Настройка порядка обхода".

Редактор программных модулей

У каждой экранной формы есть программный модуль рисунок 7. Кроме того, есть программные модули документов и глобальный модуль. В этих модулях располагается программа на встроенном языке 1С, который похож на Бейсик, но имеет свои особенности.

Рисунок 7 – Вкладка модуля

В программном модуле имеется синтаксическая подсветка. Разными цветами отображаются ключевые слова, переменные, комментарии и значения. Цветовая палитра настраивается в параметрах.

Поясним значения кнопок панели редактора программных модулей:

По тексту программы можно расставить закладки или пометки (marks), и перемещаться по ним. Полезная вещь для больших модулей в сотни и тысячи строк.

Кнопки сдвига блока текста вправо и влево. Становятся активными, когда выделено одна или несколько строчек.

Закомментировать / раскомментировать блок текста.

Кнопка автоформатирования текста программы. Нажимайте ее чаще и ваши программы будут красивыми! К сожалению, это не избавит их от всех ошибок, но их определенно станет меньше!

Открыть модуль в отладчике. Проверить модуль на синтаксические ошибки. Перейти к определенной строке модуля. Открыть окно со списком процедур и функций модуля. (полезная вещь!)

При редактировании модуля также обратите свое внимание на верхние кнопки. Там вы найдете кнопки поиска, вызова синтакс помощника, конструктуры и многое другое. Синтакс-помощник - очень полезная вещь. Там можно искать слова. Более того, при редактировании модуля можно щелкнуть правой кнопкой на любом слове и выбрать там пункт "Найти в Синтакс-помощнике".

Шаблоны предназначены для облегчения нелегкого труда программиста. Чтобы не писать длинные конструкции, а заменять их короткими словами. При этом при вводе такого сокращения оно автоматически заменяется на полную конструкцию.

Например, вам надоело постоянно писать "КонецЕсли;". Предлагаю придумать сокращение "ке". При вводе такого сокращения оно автоматически заменится на "КонецЕсли;" (даже с точкой запятой в конце!).

Можно сделать и более сложные вещи. Вы вводите слово "Пока". Понятно, что это начало цикла. При этом 1С запросит условие в диалоговом окне и далее сформирует всю конструкцию и даже поставит курсор, куда нужно, чтобы можно было продолжать писать программу.

Пока <ваше условие> Цикл КонецЦикла;

Окно для редактирования шаблонов вызывается из Синтакс-помощника правой кнопкой или через Сервис => Настройка шаблонов.

Редактор печатных форм (макетов)

У отчетов есть печатные формы, это понятно. У документов также есть печатные формы, это тоже понятно. Но печатные формы могут быть и у других объектов: справочников, журналов документов, плана счетов и т.д. Фактически у любого объекта, у которого есть экранная форма, может быть одна или несколько печатных форм.

Печатные формы состоят из ячеек, в которых содержатся текст или формулы, что очень напоминает Microsoft Excel, рисунок 8. Печатные формы формируются на встроенном языке 1С при помощи вывода секций. В печатной форме может не быть секций вообще, тогда можно вывести или все, или ничего. Но в большинстве случаев нужно выводить какую-то повторяющуюся часть много раз, например список сотрудников, список товаров и т.д. Секции могут горизонтальными и вертикальными.


Рисунок 8 – Вкладка печатной формы

Поясним значения кнопок панели редактора печатных форм:

Рисование линий, прямоугольников, размещение на печатной форме текстовых надписей, картинок, диаграмм. Редко используемые кнопки на самом деле.

Кнопка перехода в режим выбора рисунков.

Кнопка объединения нескольких ячеек в одну.

Кнопки создания/уничтожения вертикальных и горизонтальных секций. Если выделить несколько строк, а затем щелкнуть на первую кнопку, то мы создадим горизонтальную секцию. Если выделить столбцы и щелкнуть на первую кнопку, то создадим вертикальную секцию. Для каждой секции нужно задать имя, по которому мы сможем обратиться к ней из модуля.

Остальные кнопки попробуйте сами:

Список секций таблицы. Включение / выключение сетки. Включение / выключение заголовков столбцов и строк. Включение / выключение границ секций. Включение / выключение режима "Только просмотр". Фиксация строк или столбцов. При прокрутке таблицы эти строки / столбцы будут оставаться на экране.

У каждой ячейки есть свойства, которые вызываются правой кнопкой мыши рисунок 9.

Рисунок 9 – Свойства ячейки

Обратите внимание на поле Расшифровка, поскольку это очень важно и часто используется при программировании на 1С.

Администрирование базы данных

В меню Администрирование вы найдете следующие пункты:

Ведение списка пользователей

Редактирование списка пользователей, установка паролей, задание интерфейса и набора прав для каждого пользователя. Список пользователей, работающих с базой данных в данный момент времени можно посмотреть в Мониторе пользователей.

Сохранение конфигурации и данных в архив (создание резервных копий). В этом режиме определенные файлы упаковываются в zip-архив. Если вы работаете с SQL-версией, то для сохранения данных применяйте пункт "Выгрузить данные". Нажимайте эту кнопку почаще и ваши данные никогда не пропадут полностью.

Восстановить данные

Выгрузить данные

Сохранение конфигурации и данных в архив. В этом режиме вся база данных сохраняется в особый файл "dat", который затем упаковывается в zip-архив.

Загрузить данные

Восстановить конфигурацию и данные с резервной копии, созданной в предыдущем режиме.

Настройка журнала регистрации

Каждое действие пользователя регистрируется в журнал регистрации. Здесь можно настроить фильтр для этого журнала. Сам журнал регистрации можно посмотреть в Мониторе пользователей.

Тестирование и исправление ИБ

Тестирование и исправление информационной базы. Нажимайте эту кнопку почаще для профилактики и для исправления ошибок.

Кодовая страница таблиц ИБ

Установка кодовой страницы файлов DBF.

Распределенная ИБ

Доступно, если у вас установлена компонента "Управление распределенными базами данных (УРБД)".

Обычно пользователи спокойно работают с базой данных, пока вы вносите какие-то изменения в свою локальную копию. Потом вы загружаете измененную конфигурацию в рабочую базу и пользователи начинают испытывать блаженство от ваших изменений.

Объединение конфигураций

Когда нужно сохранить некоторые особенности оригинальной конфигурации, то применяют этот режим. При этом анализируются различия между конфигурациями и настраивается режим объединения. Это все очень важно и все это нужно будет изучить.

1.4.2 Встроенные функции.

Эти процедуры и функции часто применяются при программировании на 1С, поэтому знать их обязательно!

Процедура / Функция

Примечание

ОкончатЦена = Окр(Цена*0.5, 2);

Округление.

Рублей = Цел(Цена);

Получить целую часть числа.

ОблНал = Макс(ОблНал-Льготы,0); МинЗнач = Мин(значение1,значение2,значение3);

Получить минимальное или максимальное из значений. Можно передавать несколько параметров (больше двух)

Длина = СтрДлина("Иванов Иван Иванович");

Получить длину строки.

ФИО = СокрЛ(ФИО); //убрать пробелы слева ФИО = СокрП(ФИО); //убрать пробелы справа ФИО = СокрЛП(ФИО); //убрать пробелы слева и справа

Отсечение пробелов.

АБ = Лев("АБВГДЕ",2); ГДЕ = Прав("АБВГДЕ",3); БВГ = Сред("АБВГДЕ",2,3);

Вырезание подстроки слева, справа и из середины.

НомерСимвола = Найти(ФИО, " "); //найти позицию первого пробела

Поиск вхождения подстроки в строку.

НоваяСтрока = СтрЗаменить(ПрежняяСтрока," ", "_");

Замена одной подстроки на другую.

ФИОЗаглавнымиБуквами = ВРЕГ(ФИО) ФИОстрочнымиБуквами = нрег(ФИО)

Изменение регистра букв.

СегодняВ1С = РабочаяДата(); //дата в параметрах 1С СегодняВСистеме = ТекущаяДата(); //дата в операционной системе СейчасВСистеме = ТекущееВремя();

Получить текущую дату и время.

НачалоМесяца = НачМесяца(НекаяДата); КонецМесяца = КонМесяца(НекаяДата); НачалоГода = НачГода(НекаяДата); КонецГода = КонГода(НекаяДата);

Получение начала/конца месяца/года по некой дате.

Год = ДатаГод(ДатаРождения); Месяц = ДатаМесяц(ДатаРождения); Число = ДатаЧисло(ДатаРождения);

Выделить из даты год, месяц и число.

ДатаЧерезДваМесяца = ДобавитьМесяц(НекаяДата,2);

Прибавление к дате нескольких месяцев. Если число отрицательное, то отсчет ведется назад.

ПериодСтрокой = ПериодСтр(Дата1, Дата2);

Строковое представление периода, например "Январь 2002".

НекаяДата = Дата("01.01.2002"); Сообщение = "Месяц " + Строка(НомерМесяца); НекоеЧисло = Число("5");

Преобразование типов.

СуммаСКопейками = Формат(Сумма,"Ч10.2-");

Форматирование чисел, сумм и дат. Очень много вариантов форматирования!

СуммаПрописью = Пропись(Сумма);

Сумма прописью. Часто применяется в денежных документах.

Если Вопрос("Вы уверены?","Да+Нет")="Да" Тогда

Вопрос пользователю. Можно спросить "Да+Нет", "Повтор+Отмена" и т.д.

Предупреждение("Случилась ошибка!");

Сообщениию пользователю в виде окошка. Программа приостанавливается, пока пользователь не нажмет ОК.

Сообщить("Документ проведен!");

Сообщение пользователю в окно сообщений. Программа работает дальше.

Состояние("Выполнено на " + Строка(Проценты) + "%");

Сообщение пользователю в строку статуса.

глТекущийПользователь = ИмяПользователя();

Получить имя текущего пользователя.

Права = НазваниеНабораПрав();

Получить название набора прав текущего пользователя.

ТекКаталогБазы = КаталогИБ();

Получить каталог, где находится информационная база.

НачатьТранзакцию();

Если <условие ошибки> Тогда............ОтменитьТранзакцию(); КонецЕсли;

ЗафиксироватьТранзакцию();

Обработка транзакций. Транзакция - это совокупность действий, которая выполняется или вся целиком, или не выполняется ни одно из действий. Т.е. это единый блок действий, который или выполнен целиком, или не выполнен совсем. Транзакции необходимы для сохранения целостности базы данных.

СпрСотр = СоздатьОбъект("Справочник.Сотрудники");

Если ТипЗначенияСтр(Параметр)="Справочник" Тогда

Определяет тип значения.

1.4.3 Язык 1С

Язык 1С очень похож на Бейсик. В 1С все ключевые слова можно писать по-русски.


Конструкция языка 1С

Примечание

КонецПроцедуры

Простая процедура. После слова КонецПроцедуры точка с запятой не нужна, потому что это не оператор, а операторная скобка

Возврат Налог;

КонецФункции

Функция должна обязательно возвращать результат.

Если Оклад > 10000 Тогда......Результат = "Жить можно"; Иначе......Результат = "Плохо"; КонецЕсли;

Простое условие. После слова КонецЕсли должна быть точка с запятой, потому что так заканчивается оператор Если

Результат = ?(Оклад > 10000, "Нормально","Плохо");

Сокращенное Если.

Если Оклад > 10000 Тогда......Результат = "Жить можно"; ИначеЕсли Оклад > 5000 Тогда......Результат = "Плохо"; Иначе......Результат = "Так жить нельзя"; КонецЕсли;

Множественное условие. Если первое условие не выполняется, то проверяяется второе. Если второе условие не выполняется, то третье. Если ни одно из условий не выполняется то выполняется блок Иначе.

Если (Оклад > 10000) И (КодКатегории = 2) Тогда

КонецЕсли;

В составном логическом выражении скобки обязательны! (в версии 8.0 необязательны)

Пока Номер <= 50 Цикл

КонецЦикла;

Простой цикл Пока (цикл с неизвестным числом повторений). После слова КонецЦикла должна быть точка с запятой, потому что так заканчивается оператор Пока

Для Номер = 1 По 50 Цикл

КонецЦикла;

Простой цикл Для (цикл с известным числом повторений). В версии 8.0 есть еще цикл Для Каждого (for each).

Перейти ~метка;

Так оформляются метки и оператор безусловного перехода (GOTO). Чем меньше в вашей программе будет меток, тем лучше.

Пока <условие> Цикл

Если <условие> Тогда........Продолжить; КонецЕсли;

КонецЦикла;

Оператор Продолжить передает управление в начало цикла.

Пока <условие> Цикл

Если <условие> Тогда.........Прервать; КонецЕсли;

КонецЦикла;

Оператор Прервать производит досрочный выход из цикла. Управление передается на операторы после цикла.

Перем Сотр;

Явное объявление переменной.

Переменные можно не объявлять явно. При первом присвоении значения создается новая переменная.

ФИО = Фамилия + " " + Имя + " " + Отчество;

Сложение строк (конкатенация)

НекаяДата = "01.01.2002";

Переменная, которая хранит дату.

Перем глТекущийПользователь Экспорт;

Объявление глобальной переменной в Глобальном модуле. Такие переменные доступны в любом месте конфигурации.

Исключение

Предупреждение("Деление на ноль!");

КонецПопытки;

Обработка исключительных ситуаций.

Если во время выполнения операторов между словами Попытка и Исключение произошла ошибка, то управление передается на операторы между словами Исключение и КонецПопытки

Если ошибки не было, то управление передается на операторы после слова КонецПопытки.

//это комментарий

Так оформляются комментарии.

СпрСотр.ВыбратьЭлементы();

Вызов метода объекта производится как обычно, через точку.

1.5 Выбор типовой конфигурации и постановка задач

Для доступности и простоты настройки данного модуля, мы разработаем такую систему, которая была бы совместима с любой типовой конфигурацией 1С Предприятия 7.7. Это позволит увеличить спрос на данный модуль.

После обзора аналогов программного обеспечения, подходящих по функциональным возможностям, сделан вывод о том,что наиболее подходящей программой является 1С:Предприятие.

Следовательно в дальнейшем нам необходимо сделать следующее:

1 Установка 1С: Предприятие.

2 Разработка:

Документа «СырьеПродукция». В документе должна быть разработана табличная чать.

Журнала «Производство» где будет отображаться готовая продукция.

Отчета «Наличие продукции на складе». Формируется отчет по документу «СырьеПродукция».

Был произведен обзор аналогов разработки, их сравнение и обоснованный выбор наиболее подходящей. В данном случае это 1С:Предприятие. После чего система была рассмотрена более подробно. Проведена постановка задачи. Следовательно, можно приступить к разработке проектных решений.

1.6 Разработка модуля ИС предприятия по сборке ПК

1.6.1 Создание формы документа.

Для создания модуля используется конфигуратор. Для того чтобы запустить 1С в режиме конфигуратор нам нужно сначала открыть 1С:Предприятие и в открывшемся окне добавить базу данных на основе которой будет написан данный модуль, нажав на кнопку «Добавить», затем указав путь и название. В нашем случае используем типовую конфигурацию, как показано на рисунках 10 и 11.

Рисунок 10 – Окно запуска программы 1С:Предприятие

Рисунок 11 – Окно запуска программы 1С:Предприятие

В появившемся окне вводим название документа в поле идентификатор и нажимаем далее, как показано на рисунках 12-15.

Рисунок 12 – Окно конструктора создания нового документа

Рисунок 13 – Окно конструктора создания нового документа.

Рисунок 14 – Окно конструктора создания нового документа


Рисунок 15 – Окно конструктора создания нового документа

После появляется окно, где выбираются параметры нашего документа и из этого окна можно вызвать окна для непосредственного программирования модуля, как показано на рисунке 16.

Рисунок 16 – Окно выбора параметров документа.


В поле «Журнал» выбирается журнал которому будет принадлежать документ.

Рисунок 17 – Окно свойств реквизита.

В свойствах реквизита указываем идентификатор и тип значения. Если необходим выбор реквизита из справочника указываем тип «Справочник. Номенклатура», как показано на рисунке 17.

Реквизиты табличной части, это Значения столбцов в табличной части создаваемого документа. Создание реквизитов аналогично реквизитам шапки.

У реквизита «Наименование» Тип значения выбираем «Справочник. Номенклатура», это нужно для осуществления проводок. В остальных тип значения ставим «Число»


Рисунок 18 – Окно выбора реквизитов.

Выбираем реквизиты которые необходимо отразить в форме документа, как показано на рисунке 18. Дальше добавляем необходимые элементы управления в форме документа.

Добавляем кнопки «Расчет стоимости» и «Печать»

В свойствах кнопок на вкладке дополнительно в строке ввода формул вводим название процедур «РасчетСтоимости()» для кнопки «Расчет стоимости» и «Печать()» для кнопки «Печать», как показано на рисунках 19 и 20.

Рисунок 19 – Окно свойств кнопки.

Рисунок 20 – Окно свойств кнопки.

Столбец «СтоимСырья» сделаем недоступным для изменения, как показано на рисунке 21.

Рисунок 21 – Окно свойств кнопки.

Столбец «Процент» делаем еще и невидимым, как показано на рисунке 22.

Рисунок 22 – Окно свойств кнопки.

В результате получилась такая форма- рисунок 23.

Рисунок 23 – Форма документа «СырьеПродукция».

Теперь можно приступить к разработке модуля формы. Для этого перейдем на закладку Модуль. Перед началом программирования составим алгоритм программы.


Рисунок 24 – Блок-схема алгоритма работы с модулем «Производство»

На донном этапе разрабатывается документ «СырьеПродукция» разработаем его алгоритм работы, рисунок 25.

Рисунок 25 – Блок-схема алгоритма ввода нового документа.

1.6.3 Разработка модуля.

Запускаем документ «СырьеПродукция» (Рисунок 26).

Рисунок 26 – Документ «СырьеПродукция».


При открытии документа выполняется процедура «ПриОткрытии»

Данная процедура задает начальные значения переменных документа и создает строки и столбцы в таблице значений «ТзДоп». Это осуществляеться с помощью операций «НоваяКолонка», «НоваяСтрока()».

Программный код:

Процедура ПриОткрытии()

ПриЗаписиПерепроводить(1);

СуммаКом=0;

СуммаРас=0;

тзДоп.НоваяКолонка("Инф" ,"Строка",26,"Информация",30);

тзДоп.НоваяКолонка("Показ","Число" ,15,2,"Показатель",15);

тзДоп.НоваяСтрока(); тзДоп.Инф = "Стоимость комплектующих";

тзДоп.НоваяСтрока(); тзДоп.Инф = "Стоимость расходных";

тзДоп.НоваяСтрока(); тзДоп.Инф = "Затраты на работу %";

тзДоп.НоваяСтрока(); тзДоп.Инф = "Прочие затраты%";

тзДоп.НоваяСтрока(); тзДоп.Инф = "Себестоимость";

тзДоп.НоваяСтрока(); тзДоп.Инф = "";

тзДоп.НоваяСтрока(); тзДоп.Инф = "Наценка";

тзДоп.НоваяСтрока(); тзДоп.Инф = "Продажная цена";

КонецПроцедуры

Идентификаторам «СуммаКом» и «СуммаРас» присваивается нулевое значение.

В наименование выбираем название готовой продукции из справочника «Номенклатура». Задаем количество готовой продукции в партии, без этих данных будет не корректная проводка документа.

При нажатии кнопки «Новая строка» сразу происходит вызов спраочника «Материалы».

Рисунок 27 – Выбор материала из справочника.

Когда материал выбран вызывается процедура «Пересчет(Материал)».

Программный код будет выглядеть так:

Цена = Материал.Цена;

Сумма = Цена*Колво;

мат=Материал.Родитель;

СуммаКом=СуммаКом+сумма;

СуммаРас=СуммаРас+сумма;

КонецЕсли;

КонецЕсли;

КонецЕсли;

КонецЕсли;

КонецПроцедуры //Пересчет

Так как процедура вызывается из столбца «МАтериал» то ИмяРеквизита=Материал и тогда процедура по итогам условий выполняет только одну формулу Цена = Материал.Цена По этой фрмуле в столбце Стоимость сырья проставляется Цена материала из справочника Материалы.

Процедура Пересчет(ИмяРеквизита)

Если Материал.Выбран() = 1 Тогда

Если (ИмяРеквизита = "Материал") Тогда

Цена = Материал.Цена;

ИначеЕсли (ИмяРеквизита = "Колво") Тогда

Сумма = Цена*Колво;

мат=Материал.Родитель;

Если СокрЛП(мат) ="Комплектующие" Тогда

СуммаКом=СуммаКом+сумма;

тзДоп.УстановитьЗначение(1,2,СуммаКом);

Если СокрЛП(мат) ="Расходные" тогда

СуммаРас=СуммаРас+сумма;

тзДоп.УстановитьЗначение(2,2,СуммаРас);

Сообщить ("Выбран не верный элемент справочника",);

КонецЕсли;

КонецЕсли;

КонецЕсли;

КонецЕсли;

КонецПроцедуры //Пересчет

Процедура выполняет следующее:

Вычисляет сумму которая потом проставляется в форме документа Сумма = Цена*Колво,

Находит родителя выбранного материала для расчета отдельных затрат на комплектующие и расходные материалы.После чего спомощью условий увеличивает либо сумму затрат на комплектующие (СуммаКом=СуммаКом+сумма) либо на расходные материалы (СуммаРас=СуммаРас+сумма)

Записывает полученные суммы в в таблицу значений «ТЗдоп»

Если объект взят не из журнала производство, то выводится сообщение ("Выбран не верный элемент справочника",)

После того как все используемые материалы выбраны, небходимо заполнить таблицу значений. Это необходимо для учета других затрат связанных с производством (электричество, транспорт, зарплата и т.д.). Данные затраты вводяться в процентном соотношении. Если их не ввести то расчет будет не корректным.

При нажатии на необходимую строку в таблице значений вызывается процедура РедактированиеТзДоп()

Процедура РедактированиеТзДоп()

ВрЧисло = тзДоп.Показ;

ВвестиЧисло(ВрЧисло,"Введите "+тзДоп.Инф,15,3);

тзДоп.Показ = ВрЧисло;

КонецПроцедуры

В ней осуществляется вывод диалога для ввода данных и запись введенных данных в таблицу значений.

После ввода необходимых данных осуществляется расчет себестоимости и продажной цены продукции.Это осуществляется после нажатия на кнопку формы «Расчет себестоимости».При этом вызывается следующая процедура:

Процедура РасчетСтоимости()

ЗатРаб=тзДоп.ПолучитьЗначение(3,2);

ЗатПр=тзДоп.ПолучитьЗначение(4,2);

Нац=тзДоп.ПолучитьЗначение(7,2);

Если ЗатРаб*ЗатПр=0 Тогда

сообщить("Введены не все параметры") ;

КонецЕсли;

Если ЗатРаб*ЗатПр <>0 Тогда

Итого=(СуммаКом+СуммаРас)*(ЗатРаб/100+ЗатПР/100+1);

тзДоп.УстановитьЗначение(5,2,Итого);

КонецЕсли;

Если Нац=0 Тогда

тзДоп.УстановитьЗначение(8,2,Итого);

Итого1=Итого+итого*нац/100;

тзДоп.УстановитьЗначение(8,2,Итого1);

КонецЕсли;

Себестоимость=Итого1;

Всего=Себестоимость*Штук;

КонецПроцедуры

С помощью команды «ПолучитьЗначение» получаем значения из таблици значений из указанных позиций.

«Если ЗатРаб*ЗатПр=0 Тогда сообщить ("Введены не все параметры") Этот параметр нужен для того, чтобы не было нулевых значений в используемых параметрах.

Если нет нулевых значений будет выполняться расчет себестоимости, а потом и продажной цены при этом наценка может отсутствовать, для этого мы присваиваем ей значение единицы.

Далее если есть необходимость то можно распечатать конфигурацию собранного системного блока с продажными ценами и отдать потенциальным покупателям. Это осуществляеться с помощью нажатия кнопки «печать». В программе при этом вызываеться процедура печати.

Процедура Печать()

пр=ЗатРаб+ЗатПр;

Таб.ИсходнаяТаблица("Печать");

Таб.ВывестиСекцию("Шапка");

Таб.Опции(0,0,0,0);

ВыбратьСтроки();

мат=Материал.Родитель;

процент=сумма*пр/100+сумма;

Если СокрЛП(мат) ="Комплектующие" Тогда

Таб.ВывестиСекцию("Строка");

КонецЕсли;

КонецЦикла;

Таб.ВывестиСекцию("Шапка2");

ВыбратьСтроки();

Пока ПолучитьСтроку() = 1 Цикл

мат=Материал.Родитель;

процент=сумма*пр/100+сумма;

процент=процент*нац/100+процент;

Если СокрЛП(мат) ="Расходные" Тогда

Таб.ВывестиСекцию("Строка2");

КонецЕсли;

КонецЦикла;

Таб.ВывестиСекцию("Подвал");

Таб.ТолькоПросмотр(1);

Таб.Показать("Печать СырьеПродукция","");

КонецПроцедуры

Рисунок 28 – Форма печати документа «СырьеПродукция».

Создание формы печати. С помощью формы создается вид будущего документа. Здесь будут находиться: название изделия, дата документа, наименование изделия, его количество, сумма и общая себестоимость. Для этого создаем 2 шапки отдельно для комплектующих и расходных материалов и строки в которые будут копироваться данные.

Тут же рассчитываются проценты- «процент=сумма*пр/100+сумма», «процент=процент*нац/100+процент».Процент это переменная в которой храниться наценка и затраты применимые к каждому материалу в отдельности.

После расчета и формирования печатной формы документ необходимо провести. Проведение документа зависит от того какой на предприятии ведется план счетов и бухгалтерский учет. В данном варианте используются две проводки: дебет 20 – кредит 10.1 (списание материалов в производство) и дебет 43 – кредит 20 (списание готовой продукции из производства).

При нажатии пользователем кнопки «ОК» или «Закрыть» выходит диалоговое окно с выбором «провести документ или нет». При подтверждении запускается процедура обработки проведения. Данная процедура пишется не в модуле формы, а в модуле самого документа.

Процедура ОбработкаПроведения()

ВыбратьСтроки();

Пока ПолучитьСтроку() = 1 Цикл

Операция.НоваяПроводка();

Операция.Дебет.Счет = СчетПоКоду("20",ПланыСчетов.Основной);

Операция.Дебет.ВидыНоменклатуры = "Продукция";

Операция.Кредит.Счет = СчетПоКоду

("10.1",ПланыСчетов.Основной);

Операция.Кредит.Материалы = Материал;

Операция.Кредит.МестаХранения = "Основнойсклад";

Операция.Количество = Колво;

Операция.Сумма = Сумма;

КонецЦикла;

Операция.НоваяПроводка();

Операция.Дебет.Счет = СчетПоКоду("43",ПланыСчетов.Основной);

Операция.Дебет.Номенклатура = Наименование;

Операция.Дебет.МестаХранения = "Основнойсклад";

Операция.Кредит.Счет = СчетПоКоду("20",ПланыСчетов.Основной);

Операция.Кредит.ВидыНоменклатуры = "Продукция";

Операция.Количество = Штук;

Операция.Сумма = Себестоимость;

Операция.СуммаОперации = Себестоимость*Штук;

Операция.Записать();

КонецПроцедуры

Сначала делаем первую проводку, она делается в цикле так как каждый материал списывается отдельно. Задаем основные субконто проводки, Это ВидНоменклатуры, Материалы и места хранения. Также задаем содержание проводки. Количество и сумма проводки берется в зависимости от количества и суммы списываемого материала. Аналогично выполняется и вторая проводка. В данном случае она выполняется только раз, количество берется из того сколько готовой продукции выпускаем, а сумма от себестоимости товара.

Теперь нужно создать журнал, где бы отображалась готовая продукция. журнал создается с помощью конструктора.


Рисунок 30 – Окно конструктора журнала.

В следующем окне выбреются документы которым будет принадлежать данный отчет. В нашем случае нужно выбрать один документ- «СырьеПродукция», как показано на рисунке 31.

Рисунок 31 – Окно конструктора журнала.

В следующем окне нужно выбрать графы для формы. Для этого нужно нажать кнопку «Новый» и выбрать нужные нам значения, как показано на рисунках 32 и 33.

Рисунок 32 – Окно конструктора журнала.


Рисунок 33 – Окно выбора графы журнала.

В результате получится такая форма (Рисунок 34)

Рисунок 34 – Форма журнала.

Здесь будет отобраться готовая продукция ее количество, стоимость и общая сумма.

При нажатии на кнопку завершить работу выполняется процедура «ПриЗакрытии()» С помощью которой можно либо закрыть программу либо выйти из журнала.

При нажатии на кнопку печать выполняется процедура «Печать()», которая открывает форму отчета «СкладНаличие» и выводит всю имеющуюся готовую продукцию.

Процедура ПриЗакрытии()

Если Вопрос("Закончить работу?","Да+Нет")="Да" тогда

ЗавершитьРаботуСистемы(1);

СтатусВозврата(0);

КонецЕСли;

КонецПроцедуры

Процедура Печать()

ОткрытьФорму("Отчет.СкладНаличие",);

Рисунок 36 – Форма отчета.

При открытии отчета выполняется процедура «ПриОткрытии()», в ней задается рабочая дата.

При нажатии кнопки «Сформировать» выполняется процедура «Сформировать()». Здесь с 43 счета(готовая продукция) Считываются все наименования и выбираются по введенной дате. Далее выполняется запрос на получение суммы и количества «ВыполнитьЗапрос(,Дата_1,43,1,"СК")». Далее выполняется цикл, который выводит в печатную форму значения(наименование, количество и цену).

Перем Таб, БухИтоги_1;

Процедура ПриОткрытии()

Дата_1 = РабочаяДата();

КонецПроцедуры

Процедура Сформировать()

Таб = СоздатьОбъект("Таблица");

Таб.ВывестиСекцию("Шапка");

БухИтоги_1 = СоздатьОбъект("БухгалтерскиеИтоги");

БухИтоги_1.ИспользоватьСубконто(ВидыСубконто.Номенклатура,);

БухИтоги_1.ВыполнитьЗапрос(,Дата_1,43,1,"СК");

Ном_ = СоздатьОбъект("Справочник.Номенклатура");

БухИтоги_1.ВыбратьСубконто(1,"Наименование");

Пока БухИтоги_1.ПолучитьСубконто(1) > 0 Цикл

Ном_.НайтиЭлемент(БухИтоги_1.Субконто());

Количество = Формат(БухИтоги_1.СКД("К"),"Ч12.2");

Цена = Формат(БухИтоги_1.СКД("С"),"Ч12.2");

Товар_ = Ном_.Наименование;

Таб.ВывестиСекцию("Строка");

Ном = Ном + 1;

КонецЦикла;

Таб.Опции(0,0,0,0);

Таб.Защита(0);

Таб.ТолькоПросмотр(0);

Таб.ПараметрыСтраницы(1,100,1,5,5,5,5,0,0);

Таб.Показать("Ведомость о наличии готовой продукции на складе","");

Рисунок 37 – Форма отчета «СкладНаличие».

2.Экономическая часть

2.1 Расчет затрат внедряемого варианта

Целью моей дипломной работы является разработка и внедрение модуля для 1С:Предприятие.Для этого необходим компьютер с процессором (не менее) Pentium 3 и модулем памяти(не менее) 128 Мбайт RAM,работающий под управлением операционной системы Windows XP или более поздней версии. А так же необходимо приобрести программу 1С:Предприятие.Для восстановления и отладки программы вызывается техник-программист. На внедрение разработанного модуля входят затраты на обучение персонала, которые в дальнейшем будут работать с этой системой.

Затраты на вышеперечисленные программное обеспечение показаны в таблице 2.

Таблица 2 – Затраты внедряемого ПО.

Затраты на вышеперечисленные аппаратное обеспечение показаны в таблице 3.


Таблица 3 – Затраты внедряемого аппаратного обеспечения.

Затраты на канцелярию показаны в таблице 4.

Таблица 4 – Затраты на канцелярию.

Базовые затраты составляют:

Программное обеспечение-7000

Аппаратное обеспечение-16000

Канцелярия- 3200

2.2 Расчет экономической эффективности

Эффективность – показатель результативности конкретного хозяйственного или иного решения, определяемый отношением полученных от его реализации конечных результатов к затраченным ресурсам (трудовым, материальным, финансовым). Эффективность характеризует результативность затрат для достижения необходимого эффекта (намеченных целей).

Таблица 5 – Показатели эффективности от внедрения проекта

При определении экономического эффекта в расчете капитальных и текущих затрат учитываются только те затраты (статьи), которые имеют различие в базовом и внедряемом вариантах

Расчетный коэффициент экономической эффективности капитальных затрат определяется по формуле:

Или по формуле:

Где С – абсолютное изменение затрат, т.е. разница между внедряемым и базовым вариантами в рублях.

Расчет экономического эффекта производится, используя показатели базового и внедряемого вариантов на основании таблицы 2 – «Показатели эффективности от внедрения проекта»

Экономическая эффективность – это соотношение результатов деятельности человека (производственной, хозяйственной) для достижения необходимого конечного результата и затраченным ресурсам (трудовым, материальным, финансовым).

Развитие общества экономики страны предполагает систематическое повышение эффективности во всех областях человеческой деятельности, которое проявляется при абсолютном или относительном сокращении затрат.

1) Основой для расчета годового экономического эффекта является методика сопоставления приведенных затрат по базовому и внедряемому вариантам. Годовой экономический эффект определяется по формуле:

Эг=(Св+Ен*Кв)-(Сб+Ен*Кб),

Где Сб, Св – это годовые стоимостные затраты соответственно в базовом и внедряемом вариантах;

Кб,Кв – это капитальные вложения базового и внедряемого варианта;

Ен – нормативный коэффициент эффективности капитальных вложений.

Эг=(267320+40700*0.5)-(242200+23000*0.5)=290520-253700=36820

2) Срок окупаемости затрат в годах определяется по формуле:

Ток=(Кв-Кб)/Эг

Ток – это срок окупаемости;

Ток=(40700-23000)/36820=0.48

Из анализа экономической части можно сказать об эффективности внедряемого объекта. Показатели экономической части:

Годовой экономической эффект –19420

Срок окупаемости – 0.48 года

Расчетный коэффициент экономической эффективности – 0,5

2.3 Смысловое обоснование проекта

Разработка, создание и внедрение предложенного в дипломном проекте модуля позволит предприятию по сборке компьютеров автоматизировать работу бухгалтерии, повысить качество и скорость обработки информации, а также надежность ее хранения. Благодаря модулю ускорится процесс принятия решений различного административного уровня.

При внедрении модуля мы выяснили, что данный модуль помогает персоналу затрачивать намного меньше усилий и заметно сокращает время для обработки информации. Так же заметно сокращается вероятность ошибок.

Для этого модуля еще характерно то, что его использование возможно не только в данного предприятия, но и для многих других похожих организаций, занимающихся аналогичным производством.

3.1 Общие положения

Настоящие санитарные правила и нормы предназначены для предотвращения неблагоприятного воздействия на человека факторов, сопровождающих работы с видеодисплейными терминалами (ВДТ) и персональными электронно-вычислительными машинами (ПЭВМ), и определяюют санитарно-гигиенические требования к обеспечению безопасных условий труда пользователей;

Ответственность за выполнение настоящих санитарных правил возлагается на должностных лиц. специалистов и работников организаций и учреждений, применение ПЭВМ, производственное оборудование и игровые комплексы на базе ВДТ, а также занимающихся проектированием. строительством и реконструкцией помещений, предназначенных для эксплуатации ПЭВМ, в административных, учебных, общественных и промышленных зданиях:

Запрещается утверждение нормативной и технической документации на новые ПЭВМ, постановка их на производство, продажа и использование в производственных условиях, учебных процессах и в быту;

Гигиенической оценки их безопасности для здоровья человека;

Получение гигиенического сертификата в соответствии с установленными требованиями;

Руководители предприятий, организаций и учреждений вне зависимости от форм собственности и подчиненности в порядке обеспечения производственного контроля обязаны привести рабочие места пользователей ПЭВМ в соответствии с требованиями настоящих санитарных правил:

Государственный санитарно-эпидимиологическии надзор и контроль за выполнением настоящих Санитарных правил осуществляется органами и учреждениями ГСЭН РФ, а ведомственный санитарно-эпидимиологического профиля соответствующих министерств и ведомств.

3.2 Требования к ПЭВМ

Визуальные эргономические параметры ПЭВМ являются параметрами безопасности, и их неправильный выбор приводит к ухудшению здоровья пользователей. Все ПЭВМ должны иметь гигиенический сертификат, включающий, в том числе оценку визуальных параметров;

Конструкция ПЭВМ, ее дизайн и совокупность эргономических параметров должны обеспечивать надежное и комфортное считывание отображаемой информации в условиях эксплуатации;

Конструкция ПЭВМ должна обеспечивать возможность фронтального наблюдения экрана путем поворота корпуса в горизонтальной плоскости вокруг вертикальной оси в пределах +- 30 градусах с фиксацией в заданном положение;

Для обеспечения надежного считывания информации при соответствующей степени комфортности ее восприятия должны быть определены оптимальные и допустимые диапазоны визуальных эргономических параметров;

Конструкция ПЭВМ должна обеспечивать мощность экспозиционной дозы рентгеновского излучения в любой точке на расстоянии 0,05 м от экрана и корпуса ПЭВМ, при любых положениях регулировочных устройств не должна превышать 7,74x10 А/кг, что соответствует эквивалентной дозе, равной 0,1 мбэр/час (100 мкР/час);

Конструкция клавиатуры должна предусматривать:

Исполнение в виде отдельного устройства с возможностью свободного перемещения;

Опорное приспособление, позволяющее изменять угол наклона поверхности клавиатуры в пределах от 5 до 15 градусов;

Высоту среднего ряда клавиш не более 30 мм;

Расположение часто используемых клавиш в центре, внизу и справа; редко используемых - вверху и слева;

Выделение цветом, размером, форой и местом расположения функциональных групп клавиш;

Минимальный размер клавиш 5 мм, оптимальный - 15 мм;

Клавиши с углублением в центре и шагом 19 плюс-минус 1 мм;

Расстояние между клавишами не менее 3 мм;

Одинаковый ход для всех клавиш с минимальным сопротивлением нажатию 0,25 Н и максимальной - не более 1,5 Н;

Звуковую обратную связь от включения клавиш с регулировкой уровня звукового сигнала и возможности ее отключения.

3.3 Требования к помещениям для эксплуатации ПЭВМ

Помещения с ПЭВМ должны иметь естественное и искусственное освещение;

Естественное освещение должно осуществляться через светопросмы, ориентированные преимущественно на север и северо-восток и обеспечивать коэффициент естественной освещенности (КЕО) не ниже 1,2% в зонах с устойчивым снежным покровом и не ниже 1,5% на остальной территории.

Размещение рабочих мест с ПЭВМ во всех учебных и дошкольных учреждениях не допускается в цокольных и подвальных помещениях;

Площадь на одно рабочее место с ПЭВМ во всех учебных и дошкольных учреждениях должна быть не менее 6,0 квадратных метров, а объем не менее 24,0 кубических метров;

При строительстве новых и реконструкции действующих средних, средних специальных и высших учебных заведений помещения для ПЭВМ следует проектировать высотой (от пола до потолка) не менее 4,0 м;

Производственные и учебные помещения (аудитории вычислительной техники, дисплейные классы, кабинеты и др.) не должны граничить с помещениями, в которых уровни шума и вибрации превышают нормируемые значения (механические цеха, мастерские, гимнастические залы и т.п.);

Звукоизоляция ограждающих конструкций помещений с ПЭВМ должна отвечать гигиеническим требованиям и обеспечивать нормируемые параметры шума согласно требованиям настоящих Санитарных правил;

Помещения с ПЭВМ должны оборудоваться системами отопления, кондиционирования воздуха или эффективной приточно-вытяжной вентиляцией.

Визуальные эргономические параметры ПЭВМ и пределы их изменений.

Наименование параметров

Пределы значений параметров

Миним. (не менее)

Макс. (не более)

Яркость знака (яркость фона), кд/м (измеренная в темноте)

Внешняя освещенность экрана

В ходе проведения данного проектирования был создан модуль для предприятия по сборке ПК. Он соответствует всем предъявленным требованиям и поставленным задачам.

Данный модуль предполагает сборку готовой продукции из комплектующих и расходных материалов. Также можно распечатать конфигурацию собранного системного блока и прайс лист комплектующих. Также был создан отчет, который показывает наличие готовой продукции на нужную дату.

Разработанный модуль является актуальным в наше время и может быть внедрен в любое предприятие по сборке ПК.



Предыдущая статья: Следующая статья:

© 2015 .
О сайте | Контакты
| Карта сайта